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Application Note  
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This application note looks at the placement and editing of 
schematic objects in Altium.  

 

 

This application note provides a general overview of design object placement and editing methods 
used in the Schematic Editor. More detailed explanations of placing and editing some of the more 
complex objects, such as wires and parts, are also included. 

Fundamentals of object placement 

Grids and cursors 
Before placing objects in the Schematic Editor, set the girds to enable easier placement. Altium  offers 
three grid types: visible grids for navigation; snap grids for placement and electrical grids for aiding the 
creation of connections. Grids are document options, meaning that they are saved with the individual 
design, so grid settings may differ between one design document and the next. Set your grids initially in 
the Document Options dialog (Design » Document Options).  

Visible grids appear whenever the zoom level will allow them to be sufficiently spaced, displayed as 
either lines or dots. The Snap grid is the grid that the cursor is locked to when placing or moving 
schematic design objects. Overriding Snap grids are Electrical grids, which allow connections to be 
made to off-grid parts. When moving an electrical object in the 
workspace and it falls within the electrical grid range of another 
electrical object that you could connect to, it will snap to the f
object and a hotspot (red cross) will appear. The Electrical grid 
should be set slightly lower than the current Snap grid or else i
becomes difficult to position electrical objects one snap grid 
apart. 

ixed 

t 

Grids can be quickly modified, or toggled between enabled and 
disabled, through keyboard or mouse shortcuts, for example, press G to cycle through the Snap grid 
settings of 1, 5 and 10. You can also use the View » Grids submenu or the Grids right-click menu. 
Use the Schematic – Grids page of the Preferences dialog (Tools » Schematic Preferences or 
shortcut T, P) to set Imperial and Metric grid presets. 

You can also change the Cursor type to suit your needs in the Cursor section of the Schematic – 
Graphical Editing page of the Preferences dialog. For example, a large 90 degree cross that extends 
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to the edges of the design window (Large Cursor 90 option) can be handy when placing and aligning 
design objects. 

Placing design objects 
The basic steps for placing schematic design objects are outlined below. 

1. Select the object type that you want to place. You can do this by selecting an object type from the 
Place menu (e.g. Place » Wire) or by clicking on one of icons on the placement toolbars. Shortcut 
keys for placement are also available (e.g. P, W to place a wire). To place components (parts), you 
can also click the Place button in the Library panel, or select the component name from an 
available library in the Library panel and drag it into the document. 

2. When an object is selected for placement, the cursor will change to a crosshair, indicating that you 
are in editing mode, and, if relevant, the object will appear "floating" on the cursor. 

3. Press the TAB key to edit the properties of the object before placing it. This will open the Properties 
dialog for the particular object, allowing you to change various options.  

 

Once you have finished setting the properties, click OK to return to placement mode.  

The advantages of editing during placement are that objects that have a numeric identifier, such as 
a designator, will auto-increment. Also, changes made during placement can become the defaults 
for that type of object. Any changes made to object properties during placement will cause the 
default properties for the object to be updated, unless the Permanent option on the Schematic– 
Default Primitives page of the Preferences dialog (T, P) is enabled. 

4. Position the cursor and left-click, or press ENTER, to place the object. For complex objects, such 
as wires or polygons, you must continue the position-and-click procedure to place all vertices of the 
object. 

Note: If autopanning is active, you can move around the document by simply moving the cursor 
past the edge of the editing window in the direction that you wish to go. You can set the style and 
speed of autopanning in the Schematic – Graphical Editing page of the Preferences dialog. 

 



Schematic Editing Essentials 
 

AP0109 (v2.1) November 29, 2005 3 

The AutoFocus options in the Schematic – AutoFocus page of the Preferences dialog control the 
state of the schematic display, e.g. it can be configured to automatically zoom in when placing or 
editing connected objects or dim all wiring not related to the wire currently being placed. 

Other zooming and panning options are available using the shortcut keys or mouse wheel. Use 
Ctrl+wheel mouse to zoom in and out when placing. You can setup the behaviour of your mouse 
in the Schematic – Mouse Configuration page of the Preferences dialog. 

5. After placing an object you will remain in placement mode (indicated by the crosshair cursor), 
allowing you to place another object of the same type immediately. 

6. To end placement mode, right-click or press the ESC key. In some cases, such as placing a 
polygon, you may need to do this twice; once to finish placing the object and once to exit placement 
mode. When you exit placement mode, the cursor will return to its default shape. 
For more information about specific design objects press F1 when the cursor is over an object in 
the Schematic Editor, information about the object will appear in the Knowledge Center panel.  

Re-entrant editing 
The Schematic Editor includes a powerful feature called re-entrant editing which allows you to perform 
a second operation using the keyboard shortcuts without having to quit from the operation you are 
currently carrying out. For example, pressing the SPACEBAR when placing a part will rotate the object 
but will not disrupt the placement process. Once you place the part, another part will appear ready 
upon your cursor, already rotated.  

Another example of when re-entrant editing is very useful is if you start placing a wire that it needs to 
be connected to a port which you have not placed yet. There is no need to exit Place Wire mode; just 
press the Place Port shortcut keys (P, R), place the port, press Esc to exit Place Port mode and then 
connect the wire to the port. 

Placing graphical objects 
Schematic objects are divided into two groups: graphical and electrical.  

To place graphical objects, such as lines, arcs and text, use the Drawing Tools 
toolbar (available from the Utilities toolbar (View » Toolbars » Utilities). Drawing 
toolbar functions can also be accessed through the Place » Drawing Tools menu, 
except for Paste Array (Edit » Paste Array). 
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Placing electrical objects 
Schematic electrical design objects define the physical circuit you are capturing. Electrical objects 
include components (parts) and connective elements, such as wires, buses and ports. Use the Place 
menu or the Wiring toolbar (View » Toolbars » Wiring) to place electrical objects.  

 

The following sections detail the placement of two commonly used object types – parts (components) 
and wires.  

Placing Parts 
When Place » Part (PP) is selected, or you click on  in the Wiring toolbar, the Place Part dialog is 
displayed. You can enter the name of the component in the Lib Ref field or you can click on the Browse 
button (…) to locate the part by searching for and adding the required library. You can find previously 
placed parts by clicking on the History button. 

 
Parts can also be placed using the Place button in the Library panel or the Schematic Library Editor. 
Alternatively, select a component name in the Libraries panel and drag it into the document where it 
will appear floating on the cursor ready for placement. Click to place. 

When placing parts, use a snap grid that will cause the pin ends to fall on a grid point, e.g. 10. 
Remember that you can press G to cycle through the Snap grid settings of 1, 5 and 10. 
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Placing Wires 
Wires are used to represent an electrical connection b
points. When placing wires, be careful to use the 

etween 
Place » 

Wire command  and n  use the Line command by 
mistake. The Place Wire command is also available from the 
right-click menu when you are in a schematic document or 
the 

ot

Wiring toolbar. 

A wire end must fall on the connection point of an electrical object to be connected to it, e.g. the end of 
a wire must fall on the hot end of a pin to connect. As you are placing a wire, when the wire falls within 
the electrical grid range of another electrical object, the cursor will snap to the fixed object and a ‘hot 
spot’ (red cross) will appear. This hot spot guides you to where a valid connection can be made and 
automatically snaps the cursor to electrical connection points. The wire will be automatically terminated 
when it finishes on a hot spot. 

It is recommended that you set the electrical grid to be slightly smaller than the current Snap grid, or it 
becomes difficult to position electrical objects one snap grid apart.  

If you wish to place a wire that does not yet connect to another electrical object, right-click (or press 
ESC) to terminate the wire. Right-click, or press ESC, to exit wire placement mode. 

While placing wires, use the BACKSPACE key to delete the last vertex placed. 

Wire placement modes 
When placing a wire, press SHIFT+SPACEBAR to cycle through the wire placement modes. Various 
placement modes are available:  

• 90 Degree 

• 45 Degree 

• Any Angle  

• Auto Wire. 

The mode specifies how corners are created when placing wires and the angles at which wires can be 
placed. Press SPACEBAR to toggle between the Start and End sub-modes (when in 90 Degree or 45 
Degree modes), or between Any Angle and Auto Wire modes (when either of these modes is active).  

The Auto Wire mode is a special mode that allows you to automatically connect between two points on 
the schematic. The Autowirer will automatically route the wire around obstacles. When in this mode, 
press the TAB key to set the Autowirer options in the Point to Point Router Options dialog. 

Junctions 
Wires have the Auto Junction feature, which automatically inserts a Junction object (dot) if a wire starts 
or ends on another wire or runs across a pin. The display, junction size and color of 
auto-junctions and manual junctions can be controlled from the Schematic - 
Compiler page of the Preferences dialog. You can also set wire cross-overs and 
convert existing wires to cross-overs using options in the Schematic – General 
page of this dialog. 
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See Editing placed wires, later in this application note, for tips on how to modify a placed wire. 

Editing schematic design objects 
Any design objects you have placed in a schematic can be modified in a variety of ways. Objects can 
be moved around within the document, and cut, copied and pasted within and between documents. 
Also, you can edit the properties of objects to change their colors, designator or net assignment, etc. 
With some objects, such as polyline shapes (for example buses, wires, polygons and lines), you can 
graphically change the shape of the object after it has been placed. 

You can change just one object, or extend changes across your entire design using powerful editing 
options, such as queries. Several other useful tools will help you work with groups of objects at a time, 
including the Find Similar Objects dialog, the List panel and the Inspector panel.  

See the Editing Multiple Objects tutorial for more information. 

Placed components (parts) and footprints can be edited through their properties’ dialogs or changed in 
their Library Editors and updated. Pins can be edited by using the Component Pin Editor, available 
from the schematic Component Properties dialog (Edit Pins button).  

Refer to the Creating Library Components tutorial for more information about creating or editing 
parts and footprints using the Library Editors. 

Graphically editing placed objects 
To edit the look of an object in the workspace it is generally easier to do it graphically. To do this, you 
must first select the object(s).  

When an object is selected, you can move the object, or edit its graphical 
characteristics. Click on an object to select it and its ‘handles’ or vertices are 
displayed. To graphically change a selected object, click and hold on an editing 
handle. That point of the object will then become attached to the cursor, so simply 
move the mouse to a new location and release to resize. Click anywhere on a selected object to move 
it, or press the Delete key to delete it.  

Editing placed wires 
There are several ways you can change a placed wire — by moving a vertex, moving a segment, 
moving the entire wire or extending the wire to a new location. You can also edit, add or remove 
vertices through the Vertices tab in the wire’s Properties dialog. See the Editing vertices from the 
Properties dialog section for more information. 

Editing by moving a wire’s vertex 
To edit a selected wire by moving a vertex, click on the wire to select it. 
Position the cursor on the vertex you want to move until the cursor 
changes to a double arrow. Then click and drag the vertex to its new 
location, as shown below. 
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Moving a wire segment 
You can edit a selected wire by moving a segment of the wire. Select the wire and move the cursor  
over the segment until it changes to a ‘quad’ arrow. Then click and drag the segment to its new 
location, as shown below. 

 

Moving an entire wire 
To move the entire wire without modifying it, you do not have to select it first — simply click and drag. 

 

Extending a wire to a new location 
Placed wires can be extended, or added to. Select the wire and position the 
cursor on the end you want to move until the cursor changes to a double 
arrow. Click on the endpoint and drag the ‘look ahead’ segment to the new 
location and click to place. You can change the placement mode while 
moving the cursor to the new location by using SHIFT + SPACEBAR.  
To make a wire longer by extending it in the same direction, hold down the 
ALT key as you drag the selected endpoint. 

Breaking wires 
Use the Edit » Break Wire command to break the wire segment into two pieces. 
This command is also available from the right-click menu when the cursor is over a 
wire. A ‘cutter box’ displays (by default) which is placed on the wire to be cut. The 
section to be cut out is masked as shown. The cutting length is the space between the two new 
segments. Press SPACEBAR to cycle through the three cutting length modes (snap to segment, snap 
grid size multiple or fixed length). Press TAB to set the fixed cutting length and any other cutter 
options. Click to break the wire. Right-click, or press ESC, to exit break wire mode. Break Wire options 
can also be set in the Schematic – Break Wire page of the Preferences dialog.  

Note that you can also set the Components Cut Wires option in the Schematic – General page of 
the Preferences dialog. When this option and the Optimize Wires and Buses option are enabled, you 
can place a component onto a wire and the wire is cut into two segments which are automatically 
terminated onto any two ‘hot’ pins in the component. 
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Multi-wire 
Do you find that you are often need to extend a 
group of wires? The multi-wire editing mode in the 
schematic editor supports this. If multiple parallel 
wires share a coordinate for their end vertex, then 
when you click and drag to move the end of one 
wire vertex the end vertex of all other selected 
wires will also move, keeping the wire ends 
aligned.  

Moving and dragging schematic 
objects 
To move an object in Altium  is to reposition it 
without regard to objects in contact with it. Moving 
a component, for example, will not move any of the 
wires connected to it. Dragging the component, on 
the other hand, stretches the wires out after it, 
maintaining connectivity. If you wish electrical 
wiring to always stay connected when moving 
selected objects, enable the Always Drag option 
in the Schematic – Graphical Editing page of the Preferences dialog. 

 
Drag and release one vertex, and all aligned vertices 
will move to remain aligned. 

Moving objects 
You can move single, non-selected objects or multiple, selected objects, using the mouse to click-and-
drag. You could also use the Edit » Move commands, especially if you wish to move the objects to the 
front or back of other placed objects. 

You do not need to select objects first to move them around the sheet. Just click and hold until the 
electrical hotspot markers appear and drag the component/object to the new location. The cursor will 
move to the nearest electrical hotspot, e.g. the pin closest to the cursor position when you first clicked 
on the object. The Object’s Electrical Hot Spot option (default) or Center of Object option in the 
Schematic – Graphical Editing page of the Preferences dialog will determine where the object is held 
by during moving or dragging. 

While objects are being moved:
• press SPACEBAR to rotate the object. Rotation is anti-clockwise and in steps of 90°. Press 

SHIFT+SPACEBAR to rotate the object clockwise. 

• press the X or Y keys to flip the object along the X-axis or Y-axis respectively.  

• hold down the ALT key to constrain the direction of movement to the horizontal or vertical axis. 

Dragging objects 
The Edit » Move » Drag command enables you to move any object, e.g. a component (part), port, wire 
or bus, and any connected wires are moved with the object being dragged so that the connectivity of 
the schematic is maintained. The cursor changes to a crosshair, which you position over an object you 
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want to drag, and click, or press ENTER. Move the object to the required position and click, or press 
ENTER, to place. Continue moving other objects, or right-click or press ESC to exit dragging mode.  

To drag multiple selected objects and maintain connectivity, use the Edit » Move » Drag Selection 
command. 
Alternatively, you can drag objects using a shortcut key. Just hold the CTRL key as you click, hold and 
move the mouse. You can then release the CTRL key once you start dragging. This also works with 
multiple, selected objects. Note that using the CTRL key temporarily toggles the setting of the Always 
Drag option set in the Preferences dialog. 

While dragging the object: 
• press the SPACEBAR or SHIFT+SPACEBAR while dragging to change the wiring mode.  

• press CTRL+SPACEBAR while in movement mode to rotate the object. Rotation is anti-clockwise 
and in steps of 90°.  

• press the X or Y keys while in movement mode to flip the object along the X-axis or Y-axis 
respectively.  

• press SPACEBAR while moving to toggle the orthogonal wire mode for any wires connected to the 
object.  

• press the ALT key while moving, to constrain the direction of movement to the horizontal or vertical 
axis, depending on the initial direction of movement.  

Using Copy and Paste  
In the Schematic Editor, you can copy and paste objects within or between schematic documents, e.g. 
component(s) from a schematic can be copied into another schematic document. You can copy objects 
to the Windows clipboard and paste them into other documents. Text can be copied from the Windows 
clipboard into a schematic text frame. You can also directly copy/paste a table-type selection from 
another application such as Microsoft Excel, or from any grid style control within Altium Designer. More 
advanced copy/paste actions can be performed using the Smart Paste feature. 
Select the object(s) you want to copy, select Edit » Copy (Ctrl+C) and click to set a copy reference 
point on the object which will be used to accurately position the object during pasting. Note that you will 
only be prompted to click to set a reference point if the Clipboard Reference option is enabled in the 
Schematic – Graphical Editing page of the Preferences dialog. 

Using Smart Paste 
The Schematic Editor’s Smart Paste feature allows you to transform the copy of the selected objects 
into other objects as you paste them. For example you could copy a selection of Net Labels, and Smart 
Paste them as Ports, or the selected Sheet Entries could be pasted as Ports+Wires+Net Labels, all in a 
single paste action.  

 

 



Schematic Editing Essentials 
 

10 AP0109 (v2.1) November 29, 2005 

 
Sheet Entries copied and then transformed into Wires+Ports+Net Labels as they are Smart Pasted. 

You also have complete control over which of the objects in the selection set you want to paste, simply 
clear the checkbox to ignore specific object kinds when you Smart Paste your selection. 

Another handy feature is the ability to paste the selected circuitry as a graphic. Using this you can 
easily include a graphic of section of circuit on another sheet, and size it as required. Select Edit » 
Smart Paste to transform the clipboard objects as you paste them. 

On-sheet text editing 
Text strings can be edited directly on the schematic sheet. Click once to select a text string, text frame 
or note, then click a second time to edit the string directly on the schematic sheet (or press the F2 
shortcut key). This behavior can be disabled by turning off the Enable In-place Editing option in the 
Schematic – General page of the Preferences dialog.  
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Annotation and Re-annotation 
Both the Schematic Editor and the PCB Editor offer a positional annotation option. The schematic 
annotation feature allows you to match components by parameters and offers designator index control 
and suffix options for schematic sheets.  
Use the Tools » Annotate command to open the Annotate dialog, from where you can reassign the 
designators for all parts in selected sheets of the current project, so that they are unique and in 
consecutive order.  

 
Press F1 when the Annotate dialog is open for more information about this process. 

You can also use the Tools » Annotate Quiet command to assign a unique designator to any 
component that currently does not have a designator, without launching the Annotate dialog.  
If necessary, you can use the Tools » Reset Designators command to reset all component 
designators in the active project, or reset duplicate designators (Tools » Reset Duplicates). 

To re-annotate all component designators in accordance with the positional annotation scheme defined 
in the Annotate dialog, use the Tools » Force Annotate All command. 

Back Annotating (Tools » Back Annotate) will update the designators of the components in the source 
schematic sheets of the active project, using a WAS-IS file generated when re-annotating designators 
in the PCB document. 

Editing an object’s properties 
To view or edit the properties of any object, open its associated Properties dialog in one of the 
following ways: 
• when an object is ‘floating’ on the cursor during the placement procedure, press the TAB key to 

open its Properties dialog.  

• double-click on a placed object to open its properties dialog directly. 
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• select Edit » Change from the menus to enter the object change mode. Click on the object that you 
want to edit. Right-click or press ESC to exit object change mode. 

 

• click on a placed object to select it, then edit its properties in the Inspector or List panel, as 
described below. 

Editing vertices from the Properties dialog 
You can edit the co-ordinates of vertices for bus, wire, polyline and polygon objects via the Vertices 
tab of their Properties dialog. For example, the Wire properties dialog has a Vertices tab, from where 
you can edit the individual vertices of the currently selected wire object as required. 

 

The main region of the tab lists all of the vertex points currently defined for the wire. You can add new 
vertices to the wire, edit the coordinates of existing vertices, or remove selected vertices altogether. 
Click the Menu button or right-click within the main list region to access a pop-up menu from where you 
can edit, add or remove vertices or copy, paste, select or move cells. The Move Wire By XY command 
will move the entire wire object. The Move Wire By dialog will appear, from where you can enter the 
increment value to be applied to each vertex point's X and Y coordinates. 
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Editing objects in the Inspector panel 
The Inspector panel enables you to interrogate and edit the 
properties of one or more design objects in the current or open 
document(s). When used in conjunction with the Filter panel (
or the Find Similar Objects command (Shift+F, or right-click on a 
selected object and choose Find Similar Objects), you can make
changes to multiple objects of the same kind. 
Select one or more objects and press F11 to display the Inspector 
panel, or click on the Inspector tab. If the panel is not visible, c
on the SCH button in the Status bar and select Inspector, or 
select View » Workspace Panels » SCH » Inspector. You can 
also set the Double Click Runs Inspector option in the 
Schematic – Graphical Editing page of the Preferences dialog t
bring up the Inspector panel instead of the object’s Properties 
dialog when you double-click on a design object. 

Note that the Inspector panel will only show properties that are 
common to all selected objects. The attributes listed can be 
modified in the Inspector panel. Type in the new attribute, click on 
a check box or select from a drop-down list, as applicable. Press 
Enter or click on another cell in the panel to implement the 
change.  

For more information about editing multiple objects, see the 
Editing Multiple Objects tutorial. 

Editing objects in the List panel 
Select an object (or objects) and press Shift+F12 to display the List panel. When used in conjunction 
with the Filter panel (F12) or the Find Similar Objects command (Shift+F), you can target and edit 
multiple design objects. From the List panel you can change the properties of the object by selecting 
Edit from the View/Edit drop-down menu at the top of the panel. To change the location of a part, for 
example, select the X or Y coordinates and type in the new position. Press Enter to set the change. 

 

Double-click on the object in the Object Kind list of the List panel to display its Properties dialog. 
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Revision History 

Date Version No. Revision

05-Jan-2004 1.0 New product release 

24-Mar-2005 2.0 Renamed from Object Placement and Editing. Concentrates on Schematic 
Editor objects only in Altium  SP3. 

29-Nov-2005 2.1 Updated for Altium Designer 6 
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